
Open Local

Opens the Registry Editor windows, each of which represents one of the predefined keys:

HKEY_CURRENT_USER
The HKEY_CURRENT_USER window is the root of the configuration information for the user who is 

currently logged on. The user's folders, screen colors, and Control Panel settings are stored here. This information is
referred to as a user's profile.

HKEY_USERS
The HKEY_USERS window is the root of all user profiles on the computer.

HKEY_CURRENT_USER is a subkey of HKEY_USERS.

HKEY_LOCAL_MACHINE
The HKEY_LOCAL_MACHINE window contains configuration information particular to the computer (for 

any user).

HKEY_CLASSES_ROOT
The HKEY_CLASSES_ROOT window is a subkey of HKEY_LOCAL_MACHINE\Software. The information 

stored here is used to open the correct application when a file is opened using the Windows NT Explorer and for 
Object Linking & Embedding (OLE).

HKEY_CURRENT_CONFIG
The HKEY_CURRENT_CONFIG window contains information about the hardware profile used by the local 

computer at system startup.

See Also

Opening the Local Registry



Close

Closes all windows associated with the currently active window.

HKEY_CURRENT_USER
The HKEY_CURRENT_USER window is the root of the configuration information for the user who is 

currently logged on. The user's folders, screen colors, and Control Panel settings are stored here. This information is
referred to as a user's profile.

HKEY_USERS
The HKEY_USERS window is the root of all user profiles on the computer.

HKEY_CURRENT_USER is a subkey of HKEY_USERS.

HKEY_LOCAL_MACHINE
The HKEY_LOCAL_MACHINE window contains configuration information particular to the computer (for 

any user).

HKEY_CLASSES_ROOT
The HKEY_CLASSES_ROOT window is a subkey of HKEY_LOCAL_MACHINE\Software. The information 

stored here is used to open the correct application when a file is opened using the Windows NT Explorer and for 
Object Linking & Embedding (OLE).

HKEY_CURRENT_CONFIG
The HKEY_CURRENT_CONFIG window contains information about the hardware profile used by the local 

computer at system startup.

See Also

Closing Registry Editor Windows



Load Hive

Temporarily loads information contained in the HKEY_USERS and HKEY_LOCAL_MACHINE keys on another 
computer into your registry.

See Also

Loading and Unloading Registry Hives



Unload Hive

Unloads information for HKEY_USERS and HKEY_LOCAL_MACHINE predefined keys that has been temporarily 
loaded into your registry from another computer.

See Also

Loading and Unloading Registry Editor Hives



Restore

Restores a hive that has been saved as a file. The restored hive overwrites an existing registry key. A hive 
restored in this way will remain part of the registry even after you restart your system.



Save Key

Saves as a file the information contained in a registry key and in all of its subkeys.
A file created using Save Key can be loaded into the registry (with Load Hive) or can be restored (with 
Restore).

See Also

Saving a Registry Key
Loading and Unloading Registry Hives



Select Computer

When you want to connect to the registry on another computer, specify that computer in Computer. If 
necessary, you can use Select Computer to enter the computer name. By default, the list of computers in your 
domain is displayed.

See Also

Accessing the Registry of a Remote Computer



Print Subtree

Prints the currently selected key, including all of its subkeys and value entries.

See Also

Setting Up to Print Registry Data
Printing Registry Data



Printer Setup

Specifies the printer and paper orientation for printing registry data.

See Also

Setting Up to Print Registry Data
Printing Registry Data



Save Subtree As

Saves the contents of the currently selected key as a text file, including all subkeys and value entries for that 
key.

See Also

Saving a Subtree as a Text File



Exit

Exits Registry Editor.



Add Key

Adds a subkey to the currently selected key.

Key Name
 Type the name that you want to assign to your key.

Class
 Type the class (or data type) of value entry that you want to assign to the key that you have added; for 

example, type REG_SZ for string data.

See Also

Adding Keys to the Registry
Assigning a Value Entry to a Registry Key



Add Value

Adds a value entry to the currently selected key. You can assign a value entry to a new key, or you can alter the 
value entry of an existing key.

Value Name
 Type the name that you want to assign to the currently selected key.

Data Type
 Click the data type that you want to assign the added value, as follows:

To represent data as a string of binary numbers, click REG_BINARY.
To represent data as a data string, click REG_SZ.
To represent data as an expandable string, click REG_EXPAND_SZ.
To represent data as a DWORD data string, click REG_DWORD.
To represent data as a multiple string, click REG_MULTI_SZ.

See Also

Assigning a Value to a Registry Key
Adding Keys to the Registry



Delete

Deletes the currently selected item. The item can be a key or a value entry, depending on whether you clicked 
Tree Only or Data Only on the View menu. If you delete a key, all of its subkeys are also deleted. Predefined 
keys (such as HKEY_CURRENT_USER) cannot be deleted.

See Also

Deleting a Registry Key or a Value Entry
Confirming a Deletion



Binary

Opens the Binary Editor, in which you can change a value entry of any type.
If the value entry contains the type designation REG_BINARY, double-click it to open Binary Editor.

Data
 Enter or edit a data string in Data.

Data Format
 Click one of the following, depending on the format in which you want your data to appear:

To display data as binary numbers, click Binary.
To display data as hexadecimal numbers, click Hex.

See Also

Using the Binary Editor



String

Opens the String Editor dialog box, in which you can edit a value entry of the REG_SZ or REG_EXPAND_SZ type.
If the value entry contains the type designation REG_SZ or REG_EXPAND_SZ, double-click it to open String 
Editor.

String
 Enter or edit a string in String.

See Also

Using the String Editor



DWORD

Opens the DWORD Editor, in which you can edit a selected value entry.
If the value entry contains the type designation REG_DWORD, double-click it to open DWORD Editor.

Data
 Enter or edit data for the string displayed in Data.

Radix
 Click one of the numerical representations under Radix:

Binary displays the data as a binary (base-2) number.
Decimal displays the data as a decimal (base-10) number.
Hex displays the data as a hexadecimal (base-16) number.

See Also

Using the DWORD Editor



Multi String

Opens the Multi String Editor, in which you can edit multiple data strings. If the value entry contains the type 
designation REG_MULTI_SZ, double-click it to open Multi String Editor.

Data
 Add or edit a string in Value.

See Also

Using the Multi String Editor



Expand One Level

Displays the subkeys of the selected key.
If the selected key does not have any subkeys or is already expanded, this command is unavailable.

See Also

Expanding and Collapsing a Registry Tree



Expand Branch

Expands a collapsed branch, including all of the branch's subkeys. Use this command to display every key (or 
descendent) that is rooted in the selected key.
If the selected branch does not have any subkeys or is already expanded, this command is unavailable.

See Also

Expanding and Collapsing a Registry Tree



Expand All

Displays all of the subkeys in the active Registry Editor window.

See Also

Expanding and Collapsing a Registry Tree



Collapse Branch

Collapses tree levels of the selected key.
Use this command to hide the subkeys of the selected key.
If the selected key is already collapsed, this command is unavailable.

See Also

Expanding and Collapsing a Registry Tree



Tree and Data

Displays both the registry tree and the value entries of the selected key.
Tree and Data view is the default setting in Registry Editor.

See Also

Switching Between the Tree and Data Views
Expanding and Collapsing a Registry Tree



Tree Only

Displays only the registry tree; the value entries of the keys are not displayed.

See Also

Switching Between the Tree and Data Views
Expanding and Collapsing a Registry Tree



Data Only

Displays only the value entries of the currently selected key; the registry tree is not displayed.

See Also

Switching Between the Tree and Data Views
Expanding and Collapsing a Registry Tree



Split

Splits the active window. If the window is already split, this command enables you to use the arrow keys or the 
mouse to move the split bar to the left or right.
When you click Split, a vertical bar appears in the window. Use the mouse or the arrow keys to move the bar, 
and then either click the bar or press ENTER. You can press ESC to cancel Split.

See Also

Splitting a Registry Editor Window
Switching Between the Tree and Data Views



Display Binary Data

Displays the currently selected value entry as binary data.



Refresh All

Updates the windows associated with the active window to reflect any changes made to the registry.
This command is not available when Auto Refresh is selected on the Options menu.

See Also

Updating Registry Information



Refresh Active

Updates the active window to reflect any changes made to the registry.
This command is not available when Auto Refresh is selected on the Options menu.

See Also

Upadating Registry Information



Find Key

Opens the Find dialog box, which you can use to find the key name that you provide.

See Also

Finding a Registry Key



Permissions

Enables you to see which users have access to the selected key and the level of access that each user has.
Click the following for more information about this dialog box.
 Registry Key
 Owner
 Replace Permission on Existing Subkeys
 Name
 Type of Access
 Add
 Remove

See Also

Assigning Permissions on a Registry Key
Yielding Full Control of a Registry Key
Taking Ownership of a Registry Key



Registry Key

Displays the name of the key that you have selected.



Replace Permission on Existing Subkeys

Assigns a permission to both the currently selected key and all its subkeys.



Name

Lists the groups who currently have permission to access the key that you have selected.



Type of Access
 Select one of the types of access listed in Type of Access.

To enable the user to read the key but not to save any changes to the key, click Read.
To enable the user to access, edit, and to take ownership of the selected key, click Full Control.
To customize permissions for designated users or groups, click Special Access.



Add

Opens the Add Users and Groups dialog box.



Add Users and Groups

This dialog box enables you to add user names to the list of those currently authorized to access certain keys in 
the registry.
Click the following for more information about this dialog box.
 List Names From
 Names
 Add
 Show Users
 Members
 Search
 Add Names

 Type of Access

See Also

Assigning Permissions on a Registry Key



List Names From

Used to select the computer or domain whose users and groups you want to grant permission to access the 
selected key. The names are displayed in Names.



Names

Lists the users and groups in the domain selected in List Names From. To see a list of the users within any 
group, select the group in Names and click Show Users.



Add

Adds the user or group selected in Names to Add Names.



Show Users

Displays the user accounts of the domain or workstation in Names.
By default, only groups are listed in Names.



Members

Opens a Group Membership dialog box, which lists the members of the group selected in Names.



Search

Opens the Find Account dialog box, which you can use to locate a user account or group.



Add Names

Lists the groups and user accounts to be added to a permission list. 
Names (separated by semicolons) of the accounts can also be typed in Add Names.



Type of Access

Lists the types of access that you can assign to the currently selected key.



Remove

Removes a user name or group from Name.



Auditing

Enables you to audit registry events. This command can be accessed only by a user who is a member of the 
Administrators local group or that has been specifically assigned the right to audit.
Click the following for more information about this dialog box.

 Registry Key
 Audit Permission on Existing Subkeys
 Name
 Events to Audit
 Add
 Remove

See Also

Auditing Activity on a Registry Key



Registry Key

Identifies the key on which you are auditing events.



Audit Permission on Existing Subkeys

Audits activity on all subkeys of the selected key.



Name

Displays the names of currently audited groups and users.



Events to Audit

Specifies auditing for successful and unsuccessful events that were attempted on the selected key. To select an 
event to audit, select either the Success or Failure check boxes or both for to the event.
The following events can be audited:

Select To
Query Value Audit any system activity that 

attempts to read a value entry 
from a registry key

Set Value Audit system activity that 
attempts to set value entries in
a registry key

Create Subkey Audit the attempted creation 
of subkeys on a selected 
registry key

Enumerate 
Subkeys

Audit events that attempt to 
identify the subkeys of a 
registry key

Notify Audit notification events from 
a key in the registry

Create Link Audit events that attempt to 
create a symbolic link in a 
particular key

Delete Audit attempts to delete a 
registry object

Write DAC Audit the attempt of a user to 
gain access to a key for the 
purpose of writing a 
discretionary ACL (security 
permission) to the key

Read Control Audit the attempt of a user to 
access the discretionary ACL 
on a key

Add

Opens the Add Users and Groups dialog box.



Add Users and Groups

This dialog box enables you to add names to the list of users or groups being audited.
Click the following for more information about this dialog box.

 List Names From
 Names
 Add
 Show Users
 Members
 Search
 Add Names



List Names From

Used to select the computer or domain whose users and groups you want to audit. The user and group names 
are displayed in Names.



Names

Lists the users and groups in the domain selected in List Names From. To see a list of users within any group, 
select the group in Names and click Show Users.



Add

Adds the user or group selected in Names to Add Names.



Show Users

Displays the user accounts of the domain or workstation in Names.
By default, only groups are listed in Names.



Members

Opens a Group Membership dialog box, which lists members of the group selected in Names.



Search

Opens the Find Account dialog box, which you can use to locate a user account or group.



Add Names

Lists the groups and user accounts to be added to an audit list.
Names (separated by semicolons) of the accounts can also be typed in Add Names.



Remove

Removes a user name or group from Name.



Owner

Identifies the user who owns the selected key. The owner of a key can permit another user to take ownership of 
a key. In addition, a system administrator can assign a user the right to take ownership, or a system 
administrator can take ownership of a registry key.
Click the following for more information about this dialog box.

 Registry Key
 Owner
 Take Ownership

See Also

Taking Ownership of a Registry Key
Yielding Full Control of a Registry Key



Registry Key

Displays the name of the currently selected key whose owner you want to identify.



Owner

Identifies the owner of the currently selected key.



Take Ownership

Used to assume ownership of the currently selected key.



Font

Changes the appearance of characters in all Registry Editor windows.

See Also

Selecting a Font



Auto Refresh

Automatically updates all Registry Editor windows to reflect changes made to the registry.
A check mark next to Auto Refresh means that it is in effect. If it is not checked, Refresh All and Refresh 
Active on the View menu are available.
You cannot use Auto Refresh while displaying a remote registry. If you click Auto Refresh while displaying a 
remote registry, the manual refresh commands (Refresh All and Refresh Active) are not available. Although 
Auto Refresh appears to be working as though a local registry window is displayed, the contents of the remote 
window will not be refreshed.

See Also

Updating Registry Information



Read Only Mode

Protects registry data by not allowing any changes to be made to registry keys or value entries.
A check mark appears next to this command when it is in effect.

See Also

Viewing Registry Data in the Read Only Mode



Confirm on Delete

Presents a message asking you to confirm any deletion of registry data.
A check mark appears next to this command when it is in effect.

See Also

Confirming a Deletion
Deleting a Registry Key or a Value Entry



Save Settings on Exit

Enables you to save window arrangements, window size, and font size when you exit Registry Editor.



Control Menu

Contains the following commands:

Restore
Restores the window to its former size after it has been maximized or minimized.

Move
Enables you to use the keyboard to move the window to another position.

Size
Enables you to use the keyboard to change the size of the window.

Maximize
Enlarges the window to its maximum size.

Minimize
Reduces the window to an icon.

Close
Quits an application, or closes a window or dialog box.



Contents

Starts Help and displays the topics in Registry Editor Help.



Search for Help on

Opens the Index tab for Registry Editor Help, which you can use to look up Help information by keywords.



How to Use Help

Describes how to use Help.



About Registry Editor

Displays version, mode, and copyright information about Registry Editor.



Cascade

Arranges the Registry Editor windows to overlap diagonally, from the upper left to the lower right of the screen. 
The title bar of each window remains visible, making it easy for you to select any window.

See Also

Arranging Registry Editor Windows and Icons



Tile

Arranges Registry Editor windows in a square configuration, locating one window in each corner of the screen, so
that each window is visible and no windows overlap.

See Also

Arranging Registry Editor Windows and Icons



Arrange Icons

Arranges icons (reduced Registry Editor windows) so that they line up neatly and do not overlap.

See Also

Arranging Registry Editor Windows and Icons



Names of Open Windows

Lists all Registry Editor windows even if they are reduced to icons and displays a check mark by the name of the 
currently active window.



To open the local registry
 Click Open Local in the Registry menu.
The local Registry Editor windows appear, each of which bears the name of a predefined key:

HKEY_CURRENT_USER
The HKEY_CURRENT_USER window is the root of the configuration information for the user who is 

currently logged on. Information such as the user's folders, screen colors, and Control Panel settings are stored 
here. This information is referred to as a user's profile.

HKEY_USERS
The HKEY_USERS window is the root of all user profiles on the computer. HKEY_CURRENT_USER is a 

subkey of HKEY_USERS.

HKEY_LOCAL_MACHINE
The HKEY_LOCAL_MACHINE window contains configuration information particular to the computer (for 

any user).

HKEY_CLASSES_ROOT
The HKEY_CLASSES_ROOT window is a subkey of HKEY_LOCAL_MACHINE\Software. The information 

stored here is used to perform such operations as opening the correct application when a file is opened using the 
Windows NT Explorer and for Object Linking & Embedding (OLE).

HKEY_CURRENT_CONFIG
The HKEY_CURRENT_CONFIG window contains information about the hardware profile used by the local 

computer at system startup.

See Also

Closing Registry Editor Windows



To access the registry of a remote computer

1 On the Registry menu, click Select Computer.
2 In Computer, type the name of the computer which has the registry you want to access.

Note
You can access two predefined keys (HKEY_USERS and HKEY_LOCAL_MACHINE) of a remote computer 

registry.

See Also

Closing Registry Editor Windows



To close the Registry Editor windows

1 Select a window you want to close.
2 On the Registry menu, click Close.

The Registry Editor windows associated with the currently active window are no longer displayed.

See Also

Opening the Local Registry
Accessing the Registry of a Remote Computer



To add a key to the registry

1 Select the key or subkey under which you want the new key to appear.
2 On the Edit menu, click Add Key.

The Add Key dialog box appears.
3 In Key Name, type the name that you want to assign your key.
4 If you want, type the class that you want to assign to your key in Class.

Notes
When you want to add to the data stored in the registry, you must first add a registry key. If you own a key 

or have permission to access the key, you can use Add Key to add subkeys to that key.
If the HKEY_USERS or HKEY_LOCAL_MACHINE window is active, Add Key is disabled at the root of the 

key. To add a registry key to the root of these predefined keys, you must use Load Hive on the Registry menu.

See Also

Assigning a Value Entry to a Registry Key
Deleting a Registry Key or a Value Entry



To save a registry subtree as a text file

1 Select the key that you want to save as a text file.
2 On the Registry menu, click Save Subtree As.
3 Complete the Save As dialog box, and then click Save.

Note
Saving the contents of a registry key as a text file includes all of the key’s descendent keys and all of the 

value entries assigned to its descendent  keys. These are saved to the server, workstation, or shared folder that you
specify.



To search for a key in Registry Editor

1 On the View menu, click Find Key.
2 In the Find what, type the name of the key that you want to find.
3 If necessary, select the following:

To find only those occurrences that are words by themselves and not part of a larger word, select the 
Match whole word only check box.

To identify only those keys in the registry with the combination of uppercase and lowercase letters 
specified in Find what, select the Match case check box.

4 In Direction, select the direction you want the search to proceed through the registry, as follows:
To search from the insertion point or selection to the beginning of the registry tree or the selected keys, 

click Up.
 To search from the insertion point or selection to the end of the registry tree or the selected keys, click 
Down.

5 As needed, click Find Next to see each subsequent occurrence of the specified text until the search is 
complete.

See Also

Deleting a Registry Key or a Value Entry



To use the String Editor

1 Select a value entry of the type REG_SZ or REG_EXPAND_SZ.
2 On the Edit menu, click String.
3 Edit the data that is shown in String, and then click OK.

The selected value entry reflects the changes that you have made.

Note
A string is a sequence of characters usually representing humanly readable text. Many value entries in the 

registry are written in a string (REG_SZ) or in an expandable string (REG_EXPAND_SZ) format. An expandable string 
usually consists of humanly readable text, but also contains a variable that will be replaced when it is called by an 
application. For example, in the value entry %SystemRoot%\System32\Bootok.exe, %SystemRoot% is the 
expandable portion of the variable, and will be replaced by the actual location of the directory that contains the 
Windows NT system files. If a value entry in Registry Editor has a REG_SZ or a REG_EXPAND_SZ prefix, you can edit 
the value entry using the String Editor.

See Also

Using the Binary Editor
Using the DWORD Editor
Using the Multi String Editor
Deleting a Registry Key or a Value Entry



To use the Binary Editor

1 Click the value entry that you want to edit.
2 On the Edit menu, click Binary.
3 Under Data Format, make a selection, as follows:

 To represent your data as a sequence of binary digits, click Binary.
 To represent your data as a sequence of hexadecimal digits, click Hex.
4 Edit the string in Data, then click OK.

The selected value entry reflects the changes that you have made.

Notes and Tips
Many value entries in the registry are written as raw binary data. If a value entry is preceded by the prefix 

REG_BINARY, the value entry is written as binary data, and you must use the Binary Editor to edit this value entry. 
However, the Binary Editor can be used to edit any value entry, regardless of the format in which the entry is 
written.

See Also

Using the String Editor
Using the DWORD Editor
Using the Multi String Editor
Deleting a Registry Key or a Value Entry



To use the DWORD Editor

1 Click a value entry of the type REG_DWORD.
2 On the Edit menu, click DWORD.
3 Edit the string in Data.
4 In Radix, make a selection, and then click OK.

To display the data as a binary (base-2) number, click Binary.
To display the data as a decimal (base-10) number, click Decimal.
To display the data as a hexadecimal (base-16) number, click Hex.

Note
DWORD refers to data that is represented by a number that is four bytes long. If a value entry contains the

prefix REG_DWORD, the entry is written in the DWORD format.

See Also

Using the String Editor
Using the Binary Editor
Using the Multi String Editor
Deleting a Registry Key or a Value Entry



To use the Multi String Editor

1 Click a value entry of the type REG_MULTI_SZ.
2 On the Edit menu, click Multi String.
3 Edit the value entry, then click OK.

Note
If a value entry contains the prefix REG_MULTI_SZ, the value entry is written as a multiple string.

See Also

Using the String Editor
Using the Binary Editor
Using the DWORD Editor
Deleting a Registry Key or a Value Entry



To delete a registry key or a value entry

1 Click the key or value entry that you want to delete.
2 On the Edit menu, click Delete.

Note
If Confirm on Delete on the Options menu is not selected, Registry Editor automatically deletes the 

selected key or value entry. If Confirm on Delete is selected, a Warning dialog box appears, asking you to 
confirm the deletion.

You can delete both keys and value entries from your registry. However, you cannot delete predefined keys
(such as HKEY_CURRENT_USER) or change the name of a key.

See Also

Confirming a Deletion



To assign permission on a key

1 Select the key on which you want to assign permission.
2 On the Security menu, click Permissions.

The Registry Key Permissions dialog box appears. The names of users and groups with permissions to 
access the key and the levels of access they have appear in Name.

3 If you want the permission that you are setting on the selected key to override permissions previously set on 
the subkeys of the selected key, select the Replace Permission on Existing Subkeys check box.

4 Assign an access level to the selected key in Type of Access, as follows:
To enable the user to read the key contents but not to save any changes made to the file, click Read.
To enable the user to access, edit, and take ownership of the selected key, click Full Control.
To enable the user to access and to edit registry data in the selected key, click Special Access.

Note
If you own a registry key, you can specify the users and groups that can access that key. To determine who 

can access your registry keys, you need to set permissions on them. You can at any time add or remove users or 
groups from the list of those authorized to access your registry keys.

See Also

Auditing Activity on a Registry Key
Yielding Full Control of a Registry Key
Adding Users and Groups to Permissions List
Removing Users and Groups from the Permissions List



To add users or groups to the permissions list

1 In the Registry Key Permissions dialog box, click Add.
2 In List Names From, click the workstation or domain of the users and groups you want to view.

The groups for the selected domain or workstation appear in Names.
3 Click the name of the user or group, and then click Add.

The name now appears in Add Names.
4 In Type of Access, click the level of access that you want to grant to the users or groups that you are adding, 

and then click OK.
The Registry Key Permissions dialog box appears.

5 Click OK.
If you selected the Replace Permissions on Existing Subkeys check box, a dialog box appears, asking you 
to confirm the permissions change.

Notes
You must first add users and groups to Name before specifying user or group access.
You can click Show Users to display the all the users in a selected workstation or domain.
You can click Members to see the names of the users in a selected group.

See Also
Displaying Users and Groups
Selecting Members of a Group
Searching for Users and Groups



To remove a user or group from the permissions list

1 In the Registry Key Permissions dialog box, click the name of the user or group that you want to remove 
from the permissions list.

2 Click Remove.



To audit activity on a registry key

1 Select the key that you want to audit.
2 On the Security menu, click Auditing.

The Registry Key Auditing dialog box appears, listing the names of the currently audited users in Name.
3 To audit activity on the subkeys of the key that you have selected, select the Audit Permission on Existing 

Subkeys check box, if necessary.
If this check box is clear, your auditing choices affect only the selected registry key and its value entries.

4 In Name, click the name of a group or user.
5 In Events to Audit, select or clear the Success and Failure check boxes for the activities that you want to 

audit or to stop auditing and then click OK:

Select To
Query Value Audit any system activity that 

attempts to read a value entry 
from a registry key

Set Value Audit system activity that 
attempts to set value entries in 
a registry key

Create Subkey Audit the attempted creation of
subkeys on a selected registry 
key

Enumerate 
Subkeys

Audit events that attempt to 
identify the subkeys of a 
registry key

Notify Audit notification events from a
key in the registry

Create Link Audit events that attempt to 
create a symbolic link in a 
particular key

Delete Audit attempts to delete a 
registry object

Write DAC Audit the attempt of a user to 
gain access to a key for the 
purpose of writing a 
discretionary ACL (security 
permission) to the key

Read Control Audit the attempt of a user to 
access the discretionary ACL on
a key

Important
To audit a registry key, you must be logged on as a member of the Administrator's group. Or, you must 

have been specifically assigned the right to audit by the system administrator.

See Also

Searching the Audit List
Adding Users and Groups to Audit List
Removing Users and Groups from Audit List





To add users to the Audit list

1 In the Registry Key Auditing dialog box, click Add.
2 In List Names From, click the workstation or domain of the users and groups you want to view.

The groups of the selected domain or workstation appear in Names.
3 Click the name of the user or group that you want to add to the audit list, click Add, and then click OK.

Notes
You must first add users and groups to Names before specifying which events to audit.
You can click Show Users to see the users of a selected workstation or domain.
You can click Members to see the users in a selected group.

See Also

Removing Users and Groups from Audit List



To remove a user or group from the Audit list

1 In the Registry Key Auditing dialog box, click the user or group that you want to remove in Name.
2 Click Remove.



To take ownership of a registry key

1 Select the key of which you want to take ownership.
2 On the Security menu, click Owner.

The Owner dialog box appears, displaying both the name of the key and the name of the current owner.
3 Click Take Ownership.

Registry Editor grants you ownership of the selected key.

Note
You can assume ownership of the key if you have the permission of the owner of a registry key. A user who

is logged on as an administrator or a user who has been specifically assigned the right to take ownership can also 
take ownership of a registry key.

See Also

Assigning Permissions on a Registry Key
Auditing Activity on a Registry Key
Viewing Registry Data in the Read Only Mode
Confirming a Deletion



To view data in the Read Only mode
 On the Options menu, click Read Only Mode.

A check mark appears next to the command, indicating that it is in effect.

Note
Read Only Mode protects your registry data from potentially damaging, accidental changes. When you 

click Read Only Mode, Registry Editor does not save any changes that you make.

See Also

Confirming a Deletion



To activate Confirm on Delete
 On the Options menu, click Confirm on Delete.

Note
If you are not using Read Only mode, you should use Confirm on Delete to protect your registry data 

from accidental deletions. When Confirm on Delete is selected, Registry Editor presents a dialog box asking for 
confirmation any time that you delete a registry key or a value entry.

See Also

Viewing Registry Data in the Read Only Mode



To select a font

1 On the Options menu, click Font.
2 In Font, click the font that you want.
3 In Font style, click a font style.
4 In Size, click a point size.
5 In Script, click the appropriate script language for your computer.

Note
Sample displays your combination of selected font, font size, style, and script language.
When you select a font, your selection affects all Registry Editor windows.

See Also

Expanding and Collapsing a Registry Tree
Arranging Registry Editor Windows and Icons
Splitting a Registry Editor Window



To select how data appears in a Registry Editor window
 On the View menu, select one of the following:
 To view only the registry tree, click Tree Only.
 To view only the value entries of a registry tree, click Data Only.
 To view both the tree and the data, click Tree and Data.

Note
 Tree and Data is the default setting.

See Also

Expanding and Collapsing a Registry Tree
Arranging Registry Editor Windows and Icons
Splitting a Registry Editor Window



Expanding and Collapsing a Registry Tree

Registry Editor enables you to determine how the levels of a given key will be displayed in the Registry Editor 
window. You can expand a key by one level, expand a branch, or expand all the levels of a registry key. You can 
also collapse a branch so that the descendent keys of the selected key are no longer displayed.

To expand one level of a registry key

1 Select a registry key.
2 On the Tree menu, click Expand One Level.

The subkeys of the selected key appear. If the selected key has no subkeys or is already expanded, this 
command is not available.

To expand a branch of a registry tree

1 Select a registry key.
2 On the Tree menu, click Expand Branch.

Every key (or descendent) whose root is in the currently selected key appears.

To expand all of the levels of a registry tree

1 Select a registry key.
2 On the Tree menu, click Expand All.

All subkeys of the currently active key appear.

To collapse a branch of a registry key

1 Select an expanded registry key.
2 On the Tree menu, click Collapse Branch.

The selected branch no longer appears.

See Also

Splitting a Registry Editor Window
Switching Between the Tree and Data Views
Arranging Registry Editor Windows and Icons



To print a subtree

1 In the tree pane of a Registry Editor window, select a key.
2 On the Registry menu, click Print Subtree.

Note
When you print a key, Registry Editor prints the key, its descendent keys, and all of the value entries of all 

of its descendent keys.

See Also

Setting Up to Print Registry Data



To set up for printing Registry data

1 On the Registry menu, click Printer Setup.
The Print Setup dialog box appears.

2 In Name, click the name of the printer that you want to use.
3 Click to select the Size and Source of the paper you want.
4 Under Orientation, click one of the following:

To orient paper vertically and print text from top to bottom, click Portrait.
To orient paper horizontally and print text from side to side, click Landscape.

See Also

Printing Registry Data
Connecting to a Network Printer



To connect to a network printer

1 On the Registry menu, click Printer Setup.
2 In the Print Setup dialog box, click Network.

The Connect to Printer dialog box appears.
3 In Printer, type the name of a printer, and then click OK.
4 Set appropriate options in the Print Setup dialog box, and then click OK.

Notes and Tips
If you want the names of the printers in each listed domain or workgroup to appear every time that the 

Connect to Printer dialog box is displayed, select the Expand by Default check box in the Print Setup dialog 
box.

See Also

Printing Registry Data
Setting Up to Print Registry Data



To add a value entry to a registry key

1 Select the key to which you want to add a value entry.
2 On the Edit menu, click Add Value.

The Add Value dialog box appears.
3 In Value Name, type the name of the value entry that you want to create.
4 In Data Type, select the class that you want to assign to your value entry, and then click OK:

To assign a binary value entry to the selected key, select REG_BINARY.
 To assign a data string to the selected key, select REG_SZ.
 To assign an expandable string to the selected key, select REG_EXPAND_SZ.
 To assign a DWORD value to the selected key, select REG_DWORD.
 To assign data as a multiple string, select REG_MULTI_SZ.

See Also

Using the String Editor
Using the Binary Editor
Using the DWORD Editor
Using the Multi String Editor



To split a Registry Editor window

1 On the View menu, click Split.
A vertical bar appears in the window.

2 Use the mouse or arrow keys to move the bar.
3 Click to set the dividing bar at its current location.

Or, to cancel Split, press ESC.

See Also

Switching between the Tree and Data Views
Expanding and Collapsing a Registry Tree
Arranging Registry Editor Windows and Icons



To arrange Registry Editor windows and icons
 On the View menu, select one of the following:
 To arrange windows in a cascade, click Cascade.
 To arrange windows in a tile, click Tile.
 To arrange Registry Editor icons, click Arrange.

Notes
 Cascaded windows appear on the screen diagonally, from upper left to lower right, overlapping so that the 

title bar of each window remains visible.
 Tiled windows are distributed to each corner of the screen, so that each window is visible and none 

overlap.
 Icons (or reduced windows) appear at the bottom of the Registry Editor window. Each icon remains visible. 

Double-click an icon to activate that window.

See Also

Switching between the Tree and Data Views
Expanding and Collapsing a Registry Tree
Splitting a Registry Editor Window



Updating Registry Information

Registry Editor provides the following ways in which registry information can be updated:
Auto Refresh (on the Options menu)automatically updates the registry when any change is made to 

registry data.
Refresh All (on the View menu), updates all of the information in all Registry Editor windows.
Refresh Active (on the View menu), updates only the information in the active Registry Editor window.

Notes
When Auto Refresh is in effect, a check mark appears next to the command and both Refresh All and 

Refresh Active in the View menu are unavailable.
You cannot use Auto Refresh while displaying a remote registry. If you click Auto Refresh while 

displaying a remote registry, the manual refresh options (Refresh All and Refresh Active) are not available. 
Although Auto Refresh appears to be working as though a local registry window is displayed, the contents of the 
remote window will not be automatically refreshed.



Elements of the Registry Editor Interface

The Registry Editor displays windows, each of which represents a predefined key on the local computer. When 
accessing the registry of a remote computer, only two predefined keys, HKEY_USERS and 
HKEY_LOCAL_MACHINE, appear.

HKEY_CURRENT_USER
The HKEY_CURRENT_USER window is the root of the configuration information for the user who is 

currently logged on. The user's folders, screen colors, and Control Panel settings are stored here. This information is
referred to as a user's profile.

HKEY_USERS
The HKEY_USERS window is the root of all user profiles on the computer. HKEY_CURRENT_USER is a 

subkey of HKEY_USERS.

HKEY_LOCAL MACHINE
The HKEY_LOCAL_MACHINE window contains configuration information particular to the computer (for 

any user).

HKEY_CLASSES_ROOT
The HKEY_CLASSES_ROOT window is a subkey of HKEY_LOCAL_MACHINE\Software. The information 

stored here is used to open the correct application when a file is opened using the Windows NT Explorer and for 
Object Linking & Embedding (OLE).

HKEY_CURRENT_CONFIG
The HKEY_CURRENT_CONFIG window contains information about the hardware profile used by the local 

computer at system startup.
Within Registry Editor, you can assign value entries to new keys or you can alter the value entries assigned to a 
currently selected key. Value entries in the registry appear as a string which consists of three components:

 At the leftmost side of the value entry pane, the name of the value appears.
After the value name, the class or type of the value entry appears.

 After the class of the entry is the value itself.
Each value class has an editor which bears the same name as the class.

The REG_BINARY prefix identifies a value entry as binary.
 The REG_SZ prefix identifies a value entry as a data string.
 The REG_DWORD prefix identifies a value entry as a DWORD entry.
 The REG_MULTI_SZ prefix identifies a value entry as a multiple string.
 The REG_EXPAND_SZ prefix indicates that a value entry is an expandable string.
To use the editor that corresponds to these classes, either double-click the value entry or click the corresponding 
command on the Edit menu.



To run Registry Editor

1 Click Start, and then click Run.
2 Type regedt32 in Open.

To run Registry Editor from Windows NT Explorer, double-click Reget32.exe in the %SystemRoot%/System32 
folder.

Notes
 Folders represent keys in the registry and are shown in the tree view in the left-hand pane. In the right-

hand pane, the values presented in that key are displayed. Double-click a value to open an editing dialog box.
 Windows NT stores its configuration information in a database (the registry) that is organized in a tree 

format. Registry Editor enables you to inspect and modify the registry. Normally, you should not need to do so, and 
in fact, you are liable to break your system if you make incorrect changes. We expect that most administrators will 
not allow their users to run Registry Editor.



To grant full control of a registry key

1 Select the key for which you want to grant full control.
2 On the Security menu, click Permissions.

The Registry Key Permissions dialog box appears.
3 In Name, select the user to whom you want to grant full control of your registry key.
4 In Type of Access, click Full Control, and then click OK.

Note
 You can permit another user to take ownership of any registry key only if you are the current owner. To do 

so, you must first grant the user full control of the key.

See Also

Assigning Permissions on a Registry Key
Taking Ownership of a Registry Key



Loading and Unloading Registry Hives

You can load a hive that has been saved as a file into the registry or remove a loaded hive from your system. 
Load Hive and Unload Hive affect only the HKEY_USERS and HKEY_LOCAL_MACHINE predefined keys, and 
are active only when these predefined keys are selected. When you load a hive into the registry, the hive 
becomes a subkey of one of these predefined keys.

To load a hive into the registry

1 Select either the HKEY_USERS or HKEY_LOCAL_MACHINE window.
2 On the Registry menu, click Load Hive.

The Load Hive dialog box appears.
3 In Look In, click the drive, folder, or network computer and folder that contains the hive you want to load.

The files in the folder appear under Look In and the selected filename appears in File name.
4 Click Open.

A second Load Hive dialog box appears.
5 In this dialog box, type the Key Name that you want to assign to the hive, and click OK.

The hives that you have chosen now appear as subkeys of the HKEY_USERS or HKEY_LOCAL_MACHINE 
predefined keys.

To unload a hive from the registry

1 Select a hive that you have previously loaded onto your system.
2 On the Registry menu, click Unload Hive.

The hive that you have unloaded no longer exists in the registry.



Searching the Permissions List

Registry Editor provides options by which you can locate the users or groups to whom you want to assign 
permissions on a registry key using the Add Users and Groups dialog box.

Show Users enables you to see the names of all the users who have accounts in a particular domain or on
your workstation.

Members enables you to identify the members of a selected group.
Search enables you to locate either a user account or a group.

See Also
Displaying Users and Groups
Selecting Members of a Group
Searching for Users and Groups
Assigning Permissions on a Registry Key



To display all users and groups in a domain or workstation

1 On the Security menu, click Permissions.
The Registry Key Permissions dialog box appears.

2 Click Add.
The Add Users and Groups dialog box appears.

3 In List Names From, select the workstation or domain whose user accounts you want to identify.
The groups in the selected workstation or domain appear in Names.

4 Click Show Users.
The users in the selected group now appear in the Names box.

See Also

Assigning Permissions on a Registry Key



To identify the members of a group and add them to permissions

1 In the Registry Key Permissions dialog box, click Add.
The Add Users and Groups dialog box appears.

2 In List Names From, select the computer or domain whose groups you want to identify.
3 In Names, select the name of the group whose members you want to identify.
4 Click Members.

A Group Membership dialog box appears.
5 Select the name of the user or group that you want to add, and click Add.

If you want to select a user who is within a group, click Members; then select the user, and then click Add.
6 Select any other options you want in Add Users and Groups dialog box, and then click OK.
7 In the Registry Key Permissions dialog box, click OK.

See Also

Assigning Permissions on a Registry Key



To search the permissions list

1 In the Registry Key Permissions dialog box, click Add.
The Add Users and Groups dialog box appears.

2 Click Search.
The Find Account dialog box appears.

3 In Find User or Group, type the name of a user or group.
4 Select the computers and domains to be searched, as follows:

To search all the computers and domains listed, click Search All.
To search only some of the computers or domains listed, click Search Only In, and hold down the SHIFT 

key while selecting each computer or domain.
5 Click Search.

Any names found appear in Search Results.
6 Select any names you want to add to the audit list, and then click Add.
7 Select any other settings you want and then click OK in both the Add Users and Groups and then the 

Registry Key Permissions dialog boxes.

See Also

Assigning Permissions on a Registry Key



Local or Global Group Membership

This dialog box displays the users who are members of the selected group. Select the name of the user and then 
click Add to add the user’s name to the list of those being granted access to the key.



Find Account

Enables you to search for the groups or user accounts to which you want to assign permissions on a registry key.

Click the following for more information about this dialog box:
 Find User or Group
 Search
 Search All
 Search Only In
 Search Results
 Add



Find User or Group

Type the name of the user account or group that you want to find.



Search

Starts the search for the user or group.



Search All

Sets a search to look in all the listed domains.



Search Only In

Sets a search to look in only selected domains. You must also select one of the computer or domain names 
listed. Hold down the SHIFT key while selecting each computer or domain.



Search Results

Displays the results of your search.
You can click Add to include these names on the list of users authorized to access the key.



Add

Adds the user or group in Search Results to the list of those authorized to access the selected key.



Searching the Audit List

Registry Editor provides options in the Add Users and Groups dialog box to enable you to quickly locate the 
users or groups whose activity you want to audit.

Show Users enables you to see the names of all the users who have accounts in a particular domain or on
your workstation.

Members enables you to identify the members of a selected group.
Search enables you to locate either a user account or a group.

See Also
Displaying Users and Groups
Selecting Users and Groups
Searching for Users and Groups
Auditing Activity on a Registry Key



To see all domain or workstation users for auditing

1 On the Security menu, click Auditing.
The Registry Key Auditing dialog box appears.

2 Click Add.
The Add Users and Groups dialog box appears.

3 In List Names From, select the workstation or domain whose groups you want to identify.
The groups appear in Names.

4 Click Show Users.
The users in the selected group also appear in Names.

See Also

Auditing Activity on a Registry Key



To select the members of a group for auditing

1 In the Registry Key Auditing dialog box, click Add.
The Add Users and Groups dialog box appears.

2 In List Names From, select the computer or domain of the groups you want to identify.
3 In Names, select the name of the group whose members you want to identify.
4 Click Members.

A Group Membership dialog box appears.
5 Select the names of the user or group that you want to add, and then click Add.

If you want to select a user who is within a group, click Members; then select the user and click Add.
6 Select any other options you want and click OK in both the Add Users and Groups and then the Registry 

Key Auditing dialog boxes.

See Also

Auditing Activity on a Registry Key



To search the audit list

1 In the Registry Key Auditing dialog box, click Add.
The Add Users and Groups dialog box appears.

2 Click Search.
The Find Account dialog box appears.

3 In Find User or Group, type the name of a user or group.
4 Select the computers and domains to be searched as follows:

To search all the computers and domains, click Search All.
To search only some of the computers or domains, click Search Only In, and hold down the SHIFT key 

while selecting each computer or domain.
5 Click Search.

Any names found appear in Search Results.
6 Select any names you want to add to the audit list, and then click Add.
7 Select any other settings you want and click OK in both the Add Users and Groups and then the Registry 

Key Auditing dialog boxes.

See Also

Auditing Activity on a Registry Key



Search

Starts the search for the user or group.



Local or Global Group Membership

This dialog box displays the users who are members of the selected group. Select the name of the user and then 
click Add to add the user’s name to the list of those being audited.



Find Account

Enables you to search for the groups or user accounts that you want to audit.

Click the following for more information about this dialog box.
 Find User or Group
 Search
 Search All
 Search Only In
 Search Results
 Add



Find User or Group

Used to type the name of the user account or group that you want to find.



Search

Starts the search for the user or group.



Search All

Sets a search to look in all the listed domains.



Search Only In

Sets a search to look in only selected domains. You must also select one of the computer or domain names 
listed. Hold down the SHIFT key while selecting each computer or domain.



Search Results

Displays the results of your search.
You can click Add to include these names in the audit list. 



Add

Adds the user or group in Search Results to the audit list.



To save a registry key

1 Select the predefined key that you want to save to a disk.
2 On the Registry menu, click Save Key.
3 In Save In, select the drive, folder, or network computer and folder where you want to save the hive.
4 In File name, enter a name for the hive.
5 In Save as type, select All files.
6 Click Save.

The selected key, including all of its descendant keys and value entries, is saved as a file to the server, 
workstation, or shared folder that you have specified. When you use Load Hive, select the filename that you 
have just saved using Save Key.

Note
Registry Editor provides a number of commands that are designed primarily for the maintenance of your 

system. For example, Load Hive and Unload Hive allow a part of your system to be temporarily downloaded onto 
another computer for maintenance. Before a hive can be loaded or restored, it must be saved as a key, either to a 
floppy disk or to your hard disk.

See Also
Restoring a Registry Key



To restore a registry key

1 Select the predefined key in which you want to restore the hive.
2 On the Registry menu, click Restore.

The Restore Key dialog box appears.
3 In Look In, select the drive, folder, or network computer and folder on which the hive is located.
4 Select the correct filename for the hive.
5 Click Open.

Note
A restored hive overwrites an existing registry key and becomes permanent part of your configuration. For 

example, to perform maintenance on part of your system, you can use Save Key to save a hive to a disk. When 
you are ready, you can then use Restore on the Registry menu to restore the saved key to your system.



Special Access

Enables you to set special access permissions for a group or user.

Click the following for more information about this dialog box.
 Registry Key
 Name
 Full Control (All)
 Other

See Also

Assigning Special Access on a Registry Key



Registry Key

Identifies the registry key on which you are assigning special access.



Name

Identifies the user or group to which you are assigning special access.



Other

Used to specify the check boxes for the access that you want to assign.
 To assign to a user or group the right to read a value entry from a registry key, select Query Value.
 To assign to a user or group the right to set value entries in a registry key, select Set Value.
 To assign to a user or group the right to create of subkeys on a selected registry key, select Create 

Subkey.
 To assign to a user or group the right to identify the subkeys of a registry key, select Enumerate 

Subkeys.
 To assign to a user or group the right to audit notification events from a key in the registry, select Notify.
 To assign to a user or group the right to create a symbolic link in a particular key, select Create Link.
 To assign to a user or group the right to delete the selected key, select Delete.
 To assign to a user or group the right to gain access to a key for the purpose of writing to the key a 

discretionary ACL, select Write DAC.
 To assign to a user or group the right to gain access to a key for the purpose of taking ownership of it, 

select Write Owner.
 To assign to a user or group the right to gain access to the security information on the selected key, select 

Read Control.



Full Control (All)

Assigns full control of the selected registry key to the selected user or group.



To assign Special Access

1 Select the key on which you want to assign special access.
2 On the Security menu, click Permissions.

The Registry Key Permissions dialog box appears.
3 In Name, select the user or group that you want to assign special access.
4 In Type of Access list, click Special Access.
5 Select the type of control you want to assign to the selected user or group:
 To assign full control, click Full Control (All).
 To assign special access, click Other, and then select the types of access that you want to assign.
6 Click OK.
7 In the Registry Key Permissions dialog box, click OK.

Note
 Assigning special access is useful for situations in which you need to assign permissions to a key that are 

not defined by either Read or Full Control.

See Also

Assigning Permissions on a Registry Key
Searching the Permissions List



Load Hive

Enter the name that you want to assign to the hive that you are loading. 




